Trimble Identity - Login Issue
Incident Report for Trimble MAPS
Resolved
Full service has been restored and a period of stability observed. The incident has been resolved.
Posted Sep 28, 2022 - 21:00 UTC
Monitoring
Our third-party vendor has been able to address the issue and we are seeing stability in the service. The team will monitor to ensure this stability for some time, thank you for your patience in the resolution of this issue.
Posted Sep 28, 2022 - 20:43 UTC
Update
Trimble ID continues to experience an authentication issue due to an outage with Amazon Web Service's us-west-2 API gateway. However, AWS has identified the root cause and expects the issues to progressively resolve within hours.

We will keep monitoring, and provide updates as we approach full resolution.

For further information from AWS, you can see the most current information at https://health.aws.amazon.com/health/status.
Posted Sep 28, 2022 - 19:59 UTC
Identified
The issue has been identified and we are actively working on a resolution.
Posted Sep 28, 2022 - 17:18 UTC
Investigating
Some customers are experiencing login issues with the Trimble Maps web tools. We are actively investigating the issue and apologize for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Sep 28, 2022 - 17:08 UTC
This incident affected: Tools & Utilities (CoPilot FleetPortal Services, Content Tools) and Hosted Services (PC*MILER Web).