Performance Issues with Route Reporter API (AWS)

Incident Report for Trimble MAPS

Resolved

The system optimizations are complete, and the Route Reporter API on AWS has been fully stabilized. All services are now operating normally.
Posted Apr 20, 2026 - 21:11 UTC

Identified

We are continuing to work on the performance issues affecting the Route Reporter API on AWS. Our team is currently performing system-level optimizations to stabilize the environment.
Posted Apr 20, 2026 - 20:12 UTC

Investigating

We are currently investigating reports of intermittent failures and inconsistent data returns within the Route Reporter API on our AWS environment. Our engineering team has identified a database issue and is actively performing repairs.
Posted Apr 20, 2026 - 19:24 UTC
This incident affected: Tools & Utilities (RouteReporter).