Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 08, 2026 - 23:00 UTC
Scheduled
We will be performing scheduled proactive maintenance on Monday, June 8, 2026, from 7:00 PM to 8:00 PM EDT (Tuesday, June 9, 12:00 AM – 1:00 AM BST). During this window, we will validate and execute the Auto Minor Version Upgrade to PostgreSQL 17.9 across identified RDS instances to ensure application compatibility and prevent unexpected future downtime.
Expected Impact: The RouteReporter API and Metrics Dashboard may experience intermittent connectivity or brief service interruptions for approximately 30 minutes to 1 hour while instances reboot. We appreciate your patience as we complete these critical infrastructure updates.
Posted Jun 01, 2026 - 17:43 UTC
This scheduled maintenance affected: Tools & Utilities (RouteReporter).