Increased Latency
Incident Report for Trimble MAPS
Resolved
Full service has been restored and a period of stability observed. The incident has been resolved.
Posted Mar 13, 2023 - 20:48 UTC
Monitoring
A fix has been deployed. Services are now being monitored to confirm a return to normal operation.
Posted Mar 13, 2023 - 19:58 UTC
Investigating
Some customers are experiencing increased latency on the Trimble Maps Web Services starting at 1PM EST on 3/13/2023. We are actively investigating the issue and apologise for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Mar 13, 2023 - 18:39 UTC
This incident affected: Hosted Services (PC*MILER Web Services, PC*MILER Web, Trip Management).