Hyperlocal Weather Outage

Incident Report for Trimble MAPS

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:39 UTC

Update

We are seeing service health improve from our upstream weather provider. We are continuing to monitor the situation.
Posted Jun 12, 2025 - 19:52 UTC

Identified

Due to an issue with our Hyperlocal Weather provider, this feature is currently experiencing an outage. We will keep you updated on the status as we work towards a resolution.
Posted Jun 12, 2025 - 19:31 UTC
This incident affected: Weather Services (Hyperlocal Weather).