Major AWS Outage Affecting Multiple Trimble Services
Incident Report for Trimble MAPS
Resolved
Full service has been restored and a period of stability observed. The incident has been resolved.

As you may be aware, significant IT disruptions are affecting many companies around the world today, including Trimble. The technical issues we were experiencing are due to a global third-party outage, which is impacted Trimble services and other businesses worldwide.

We understand the impact your business experienced due to the outage, and appreciate your patience. Our support teams are available to answer any questions you may have at this time.
Posted Jul 19, 2024 - 16:11 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 16:04 UTC
Update
Services are continuing to be monitored to confirm a return to normal operation.
Posted Jul 19, 2024 - 13:49 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 12:26 UTC
Monitoring
A fix has been deployed. Services are now being monitored to confirm a return to normal operation.
Posted Jul 19, 2024 - 12:04 UTC
Identified
Engineers have identified the issue and are now working to apply a fix across all affected Services. This process may result in individual Services being restored over a period as that fix is rolled out across them all.
Posted Jul 19, 2024 - 10:21 UTC
Update
Customers continue to experience outages on multiple AWS Services using Windows machines globally. Engineers are investigating the cause and potential mitigations as a matter of urgency. Further updates will be sent as this progresses. We apologise for the inconvenience caused.
Posted Jul 19, 2024 - 09:13 UTC
Investigating
Customers are experiencing outages on multiple AWS Services using Windows machines globally. Engineers are actively investigating the issue as a matter of urgency and we apologise for the inconvenience caused. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Jul 19, 2024 - 07:26 UTC
This incident affected: Hosted Services (PC*MILER Web Services, Trimble MAPS (formerly ALK Maps), PC*MILER Web Services - Route Matrix & Time Window Optimization Services, PC*MILER Web, Trip Management, Web Tools Authentication (Trimble Identity)), Tools & Utilities (CoPilot FleetPortal Services, Licensing and Activation Services, Content Tools), and Traffic Services (CoPilot Traffic, PC*MILER (On Premise) Traffic Service).