Increased Latency
Incident Report for Trimble MAPS
Resolved
Full service has been restored and a period of stability observed. The incident has been resolved.
Posted Oct 05, 2023 - 19:55 UTC
Monitoring
A fix has been deployed. Services are now being monitored to confirm a return to normal operation.
Posted Oct 05, 2023 - 19:32 UTC
Investigating
Starting at 12:15 PM ET - some customers are experiencing increased latency on the Routing API Services. We are actively investigating the issue and apologise for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Oct 05, 2023 - 18:15 UTC
This incident affected: Hosted Services (PC*MILER Web Services, PC*MILER Web).