Increase in Routing Latency

Incident Report for Trimble MAPS

Resolved

We have resolved the latency issue and confirm that the latency spikes from this morning are no longer occurring.
Posted Jan 27, 2026 - 17:31 UTC

Monitoring

We are seeing occasional increase in latency on Routing service. The latency remains higher for around 5 mins before recovering. This started around 07:52 AM EST with the last one observed at 08:50. We are actively monitoring the servers and scaling as necessary. Apologize for any inconvenience. If you require immediate assistance, please contact our Support Team.
Posted Jan 27, 2026 - 14:24 UTC
This incident affected: Hosted Services (PC*MILER Web Services, PC*MILER Web).