Full service has been restored and a period of stability observed. The incident has been resolved.
Posted Apr 17, 2025 - 14:25 UTC
Investigating
Some customers are experiencing increased latency on the Mapping Services. We are actively investigating the issue and apologise for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Apr 17, 2025 - 13:10 UTC
This incident affected: Hosted Services (PC*MILER Web Services, Trimble MAPS (formerly ALK Maps), PC*MILER Web).