Increased Latency
Incident Report for Trimble MAPS
Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 20:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2023 - 19:52 UTC
Investigating
Some customers are experiencing increased latency on our Hosted Services. We are actively investigating the issue and apologise for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Jun 05, 2023 - 19:31 UTC
This incident affected: Hosted Services (PC*MILER Web Services, PC*MILER Web).