Full service has been restored and a period of stability observed. The incident has been resolved.
Posted Apr 13, 2026 - 17:42 UTC
Update
A fix has been implemented and we are seeing a return to normal performance levels for Satellite Imagery. Map tiles are currently rendering within expected timeframes. We will continue to monitor the stability of the service before declaring full resolution.
Posted Apr 13, 2026 - 17:17 UTC
Monitoring
A fix has been deployed. Services are now being monitored to confirm a return to normal operation.
Posted Apr 13, 2026 - 16:44 UTC
Investigating
We are currently investigating reports of increased latency when loading Satellite Imagery across Trimble MAPS platforms. Users may experience slower-than-usual rendering or "patchy" tile loading in the map view. We are working to identify the root cause and will provide an update as soon as more information is available.
Posted Apr 13, 2026 - 16:18 UTC
This incident affected: Hosted Services (Trimble MAPS (formerly ALK Maps)).